Jump to content
Deye

v3.3.14.3

Recommended Posts

Deye

running the example for _GUICtrlButton_GetState .. Does anything for you ?

And Mind to\for a preference:  how can I have 2 installed libraries for autoit versions to then tell Scite to run from anyone chosen .. If there is a known way ..

Don't like Uninstalling\reinstalling just to debug something out 

Thanks

Share this post


Link to post
Share on other sites
BrewManNH
53 minutes ago, Deye said:

running the example for _GUICtrlButton_GetState .. Does anything for you ?

It does what it's supposed to do. The text won't change as you click things, because it's not supposed to.

There's an #Autoit3wrapper directive that you can tell it to run the beta installation

#AutoIt3Wrapper_Version=Beta

And you could install a second version in the beta folder instead of the beta.

  • Like 1

If I posted any code, assume that code was written using the latest release version unless stated otherwise. Also, if it doesn't work on XP I can't help with that because I don't have access to XP, and I'm not going to.
Give a programmer the correct code and he can do his work for a day. Teach a programmer to debug and he can do his work for a lifetime - by Chirag Gude
How to ask questions the smart way!

I hereby grant any person the right to use any code I post, that I am the original author of, on the autoitscript.com forums, unless I've specifically stated otherwise in the code or the thread post. If you do use my code all I ask, as a courtesy, is to make note of where you got it from.

Back up and restore Windows user files _Array.au3 - Modified array functions that include support for 2D arrays.  -  ColorChooser - An add-on for SciTE that pops up a color dialog so you can select and paste a color code into a script.  -  Customizable Splashscreen GUI w/Progress Bar - Create a custom "splash screen" GUI with a progress bar and custom label.  -  _FileGetProperty - Retrieve the properties of a file  -  SciTE Toolbar - A toolbar demo for use with the SciTE editor  -  GUIRegisterMsg demo - Demo script to show how to use the Windows messages to interact with controls and your GUI.  -   Latin Square password generator

Share this post


Link to post
Share on other sites
AdamUL

Use the AutoIt3Wrapper directive #AutoIt3Wrapper_Autoit3Dir.  Get the zip file version of the AutoIt version that you want to use.  It can be multiple versions in different directories.  You can then use any version of AutoIt that you want.  I have versions going back to 3.3.8.1 in the AutoIt directory, and use this directive to use the version that I need for the script that I am working on.  This works really well when I need to do simple bug fixes on an old script using the old version it was wrote for.  Example below.  

;~ #AutoIt3Wrapper_Autoit3Dir=C:\Program Files (x86)\AutoIt3\3.3.8.1  ;Optionally override the AutoIt3 install directory to use.
;~ #AutoIt3Wrapper_Autoit3Dir=C:\Program Files (x86)\AutoIt3\3.3.12.0  ;Optionally override the AutoIt3 install directory to use.
;~ #AutoIt3Wrapper_Autoit3Dir=C:\Program Files (x86)\AutoIt3\3.3.14.2  ;Optionally override the AutoIt3 install directory to use.
#AutoIt3Wrapper_Autoit3Dir=C:\Program Files (x86)\AutoIt3\3.3.14.3  ;Optionally override the AutoIt3 install directory to use.

This also allows you to test new versions of AutoIt without installing them, including Beta versions.  

 

Adam

  • Like 1

Share this post


Link to post
Share on other sites
Deye

Thanks guys

Share this post


Link to post
Share on other sites
whopacha

Will there be a new: SciTE4AutoIt3.exe release to match version 3.3.14.3?

Also, my biggest issue with any version above 3.3.12.0 is this: https://www.autoitscript.com/trac/autoit/ticket/3097
Can anybody confirm if this has been fixed yet or not?

Most of the work I do involves automating Internet explorer but recently I've started making use of microsoft access.

My problems arise when i want to automate IE AND make use of Access connectivity. Although we use 64 bit machines, we have 32 bit office drivers installed and the only way I've found to communicate with access through autoit is if I compile with 32 bit.

However I run into IE issues (seemingly completely random errors) where I will lose control of IE objects and get random errors all throughout my code if i compile autoit version 3.3.14.2 as 32 bit. (compiling in 3.3.14.2 as 64 bit works fine for IE and i dont get any IE errors but i cant use 32 bit access drivers!)

My ONLY solution to make use of interacting with IE and an access database is to compile as 32 bit in 3.3.12.0

Something happened somewhere after 3.3.12.0 and i believe ticket 3097 as linked above is the same issue im experiencing.

IT compiles fine with AutoIt3_x64.exe but thats not an option for me. I need to compile as 32 bit!

 

ticket #3097 was opened 3 years ago!

I would love to be able to use the newest autoit release, with SciTE4AutoIt3.exe already set up for me (i always forget how to go about reconfiguring the scite lite version) with a fix for the ticket 3097 issue that make using IE and 32 bit impossible!

Share this post


Link to post
Share on other sites
mLipok
25 minutes ago, whopacha said:

Can anybody confirm if this has been fixed yet or not?

When it be fixed you will see it in Track Ticketing system.
When it be released you will see in change log.

 


Signature beginning:   Wondering who uses AutoIT and what it can be used for ?
* GHAPI UDF - modest begining - comunication with GitHub REST API Forum Rules *
ADO.au3 UDF     POP3.au3 UDF     XML.au3 UDF    How to use IE.au3  UDF with  AutoIt v3.3.14.x  for other useful stuff click the following button

Spoiler

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind. 

My contribution (my own projects): * Debenu Quick PDF Library - UDF * Debenu PDF Viewer SDK - UDF * Acrobat Reader - ActiveX Viewer * UDF for PDFCreator v1.x.x * XZip - UDF * AppCompatFlags UDF * CrowdinAPI UDF * _WinMergeCompare2Files() * _JavaExceptionAdd() * _IsBeta() * Writing DPI Awareness App - workaround * _AutoIt_RequiredVersion() * Chilkatsoft.au3 UDF * TeamViewer.au3 UDF * JavaManagement UDF * VIES over SOAP * WinSCP UDF * GHAPI UDF - modest begining - comunication with GitHub REST APIErrorLog.au3 UDF - A logging Library
 

My contribution to others projects or UDF based on  others projects: * _sql.au3 UDF  * POP3.au3 UDF *  RTF Printer - UDF * XML.au3 UDF * ADO.au3 UDF SMTP Mailer UDF * Dual Monitor resolution detection * * 2GUI on Dual Monitor System * _SciLexer.au3 UDF *

Useful links: * Forum Rules * Forum etiquette *  Forum Information and FAQs * How to post code on the forum * AutoIt Online Documentation * AutoIt Online Beta Documentation * SciTE4AutoIt3 getting started * Convert text blocks to AutoIt code * Games made in Autoit * Programming related sites * Polish AutoIt Tutorial * DllCall Code Generator * 

Wiki: Expand your knowledge - AutoIt Wiki * Collection of User Defined Functions * How to use HelpFile * Good coding practices in AutoIt * 

IE Related:  * How to use IE.au3  UDF with  AutoIt v3.3.14.x * Why isn't Autoit able to click a Javascript Dialog? * Clicking javascript button with no ID * IE document >> save as MHT file * IETab Switcher (by LarsJ ) * HTML Entities * _IEquerySelectorAll() (by uncommon) * IE in TaskScheduler

I encourage you to read: * Global Vars * Best Coding Practices * Please explain code used in Help file for several File functions * OOP-like approach in AutoIt * UDF-Spec Questions *  EXAMPLE: How To Catch ConsoleWrite() output to a file or to CMD *

"Homo sum; humani nil a me alienum puto" - Publius Terentius Afer
"Program are meant to be read by humans and only incidentally for computers and execute" - Donald Knuth, "The Art of Computer Programming"
:naughty:  :ranting:, be  :) and       \\//_.

Anticipating Errors :  "Any program that accepts data from a user must include code to validate that data before sending it to the data store. You cannot rely on the data store, ...., or even your programming language to notify you of problems. You must check every byte entered by your users, making sure that data is the correct type for its field and that required fields are not empty."

Signature last update: 2018-10-31

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×