decow

Trying to use _IENavigate put it fails after 2 attempts

16 posts in this topic

#1 ·  Posted

Hi guys, after 2 _IENavigate I get the following error:

 

"C:\Program Files (x86)\AutoIt3\Include\IE.au3" (272) : ==> The requested action with this object has failed.:
$oObject.navigate($sUrl)
$oObject^ ERROR


I have read something about permission and changes on windows but I cant find the proper url now...

How can I fix this? I am using a brand new machine with windows 10 pro.

Share this post


Link to post
Share on other sites



#2 ·  Posted

It should be, have you read the Autoit helpfile?.

#include <IE.au3>
Local $sURL = "www.autoitscript.com" ; Example URL
Local $oIE = _IECreate($sURL)

 

Share this post


Link to post
Share on other sites

#3 ·  Posted

Yes, I have included the au3 file.

Here is a bit of my code:
 

Local $oIE = _IECreate("about:blank")

While 1

    Sleep(10000)
    $navigateReturn = _IENavigate($oIE, $baseURL & RandomizeHash(), 0)

WEnd

 

Share this post


Link to post
Share on other sites

#4 ·  Posted

Sorry about my post above still half asleep :)  It kind of looks like $oIE is no longer an object, so question is are the pages being closed at any point?

Share this post


Link to post
Share on other sites

#5 ·  Posted (edited)

9 hours ago, Subz said:

Sorry about my post above still half asleep :)  It kind of looks like $oIE is no longer an object, so question is are the pages being closed at any point?

No, just a few clicks here and there.

 

Then the loop starts over again.

 

Sometimes I get random errors like:

--> IE.au3 T3.0-2 Error from function _IELoadWait, $_IESTATUS_ClientDisconnected (-2147023174, Browser has been deleted prior to operation.)

Seems like the object its losing the connection with IE instance.

Edited by decow
more errors

Share this post


Link to post
Share on other sites

#6 ·  Posted

Check to see if you are somehow navigating between secure and non secure sites. That would possibly explain this behavior. 

Share this post


Link to post
Share on other sites

#7 ·  Posted

its always the same site.

 

What do you mean by secure or unsecure

Share this post


Link to post
Share on other sites

#8 ·  Posted

Http vs https

Share this post


Link to post
Share on other sites

#9 ·  Posted

4 hours ago, Danp2 said:

Http vs https

I dont think that this is the issue.

1 - the exact same script works on my old computer. Also windows 10, but I cant remember if I did some change on IE security on something like this.
2 - I was having some sort of connection issue when acessing sites. They all seem not to load, but if I waited like 2-3 seconds they sould show up. Then I added google dns and it seems to have fixed it.

Share this post


Link to post
Share on other sites

#10 ·  Posted

Let me explain what I am trying to do here.

I am trying to collect every hashtag posted on an instagram specific hashtag so I can relate and create correlations between the hashtags.

I reduced the code to this so you can have a feeling of the issue (if that happens with you). Ps: you have to be logged on instagram on Internet Explorer.

 

#include <IE.au3>

HotKeySet("+{END}", "Terminate")

Local $oIE = _IECreate("about:blank")

While 1
   Sleep(10000)
   $navigateReturn = _IENavigate($oIE, "https://www.instagram.com/explore/tags/ironfist", 0)
WEnd

Func Terminate()
    Exit
EndFunc   ;==>Terminate


Whe I run this code I get every time the navigate hits after the first one:

--> IE.au3 T3.0-2 Error from function _IENavigate, $_IESTATUS_InvalidObjectType

 

Does this happen to someone else?

Share this post


Link to post
Share on other sites

#11 ·  Posted

What version of AutoIt are you using? FWIW, I'm running a modified version of your script and just past 500 iterations without any issues.

Share this post


Link to post
Share on other sites

#12 ·  Posted

19 hours ago, Danp2 said:

What version of AutoIt are you using? FWIW, I'm running a modified version of your script and just past 500 iterations without any issues.

v3.3.14.2

 

Have you made any changes that could make a difference for me?

Share this post


Link to post
Share on other sites

#13 ·  Posted

On 16.03.2017 at 9:11 PM, decow said:

Yes, I have included the au3 file.

Here is a bit of my code:
 

Local $oIE = _IECreate("about:blank")

While 1

    Sleep(10000)
    $navigateReturn = _IENavigate($oIE, $baseURL & RandomizeHash(), 0)

WEnd

 

Third param set it to 1

 


Signature beginning:   Wondering who uses AutoIT and what it can be used for ?
* GHAPI UDF - modest begining - comunication with GitHub REST API *
ADO.au3 UDF     POP3.au3 UDF     XML.au3 UDF    How to use IE.au3  UDF with  AutoIt v3.3.14.x  for other useful stuff click the following button

Spoiler

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind. 

My contribution (my own projects): * Debenu Quick PDF Library - UDF * Debenu PDF Viewer SDK - UDF * Acrobat Reader - ActiveX Viewer * UDF for PDFCreator v1.x.x * XZip - UDF * AppCompatFlags UDF * CrowdinAPI UDF * _WinMergeCompare2Files() * _JavaExceptionAdd() * _IsBeta() * Writing DPI Awareness App - workaround * _AutoIt_RequiredVersion() * Chilkatsoft.au3 UDF * TeamViewer.au3 UDF * JavaManagement UDF * VIES over SOAP * WinSCP UDF * GHAPI UDF - modest begining - comunication with GitHub REST API *

My contribution to others projects or UDF based on  others projects: * _sql.au3 UDF  * POP3.au3 UDF *  RTF Printer - UDF * XML.au3 - BETA * ADO.au3 UDF SMTP Mailer UDF *

Useful links: * Forum Rules * Forum etiquette *  Forum Information and FAQs * How to post code on the forum * AutoIt Online Documentation * AutoIt Online Beta Documentation * SciTE4AutoIt3 getting started * Convert text blocks to AutoIt code * Games made in Autoit * Programming related sites * Polish AutoIt Tutorial * DllCall Code Generator * 

Wiki: Expand your knowledge - AutoIt Wiki * Collection of User Defined Functions * How to use HelpFile * Best coding practices * 

IE Related:  * How to use IE.au3  UDF with  AutoIt v3.3.14.x * Why isn't Autoit able to click a Javascript Dialog? * Clicking javascript button with no ID * IE document >> save as MHT file * IETab Switcher (by LarsJ ) * HTML Entities * _IEquerySelectorAll() (by uncommon) * 

I encourage you to read: * Global Vars * Best Coding Practices * Please explain code used in Help file for several File functions * OOP-like approach in AutoIt * UDF-Spec Questions *  EXAMPLE: How To Catch ConsoleWrite() output to a file or to CMD *

"Homo sum; humani nil a me alienum puto" - Publius Terentius Afer
"Program are meant to be read by humans and only incidentally for computers and execute" - Donald Knuth, "The Art of Computer Programming"
:naughty:  :ranting:, be  :) and       \\//_.

Anticipating Errors :  "Any program that accepts data from a user must include code to validate that data before sending it to the data store. You cannot rely on the data store, ...., or even your programming language to notify you of problems. You must check every byte entered by your users, making sure that data is the correct type for its field and that required fields are not empty."

Signature last update: 2017-06-04

Share this post


Link to post
Share on other sites

#14 ·  Posted

38 minutes ago, mLipok said:

Third param set it to 1

 

This is what happens when I set it to 1:

 

--> IE.au3 T3.0-2 Error from function _IELoadWait, $_IESTATUS_ClientDisconnected (-2147417848, Browser has been deleted prior to operation.)

 

Share this post


Link to post
Share on other sites

#15 ·  Posted

5 hours ago, decow said:

Have you made any changes that could make a difference for me?

No, nothing substantial. I feel that your issue is environmental. Is your PC fully updated with all Windows updates?

Share this post


Link to post
Share on other sites

#16 ·  Posted

21 hours ago, Danp2 said:

No, nothing substantial. I feel that your issue is environmental. Is your PC fully updated with all Windows updates?

Yes... I have been testing with other sites...

some work, some dont...

 

I dont know what else to do.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now