Jump to content
sammy1983

Unable to click on "Upload file" button

Recommended Posts

sammy1983

Hi Techies,

Need help. I am unable to locate and click on "Upload".

<div class="CommandBarItem-uploadInput" data-bind="automation: 'fileInput', fileInput: { isFolderUpload: false, onInputChange: onInputChange, css: 'CommandBarItem-fileInput'}" data-automationId="fileInput">
<input tabindex="-1" class="CommandBarItem-fileInput" type="file" multiple="">
</div>

I tried like this.

$oLinks = _IETagNameGetCollection($oIE, "input")
For $oLink In $oLinks
    If String($oLink.type) = "file" And String($oLink.class) = "CommandBarItem-fileInput" Then
        _IEAction($oLink, "click")
        ExitLoop
    EndIf
Next

2nd attempt:

Local $oInputs = _IETagNameGetCollection($oIE, "div")
For $oInput In $oInputs
    If String($oInput.class) = "CommandBarItem-uploadInput" Then _IEAction($oInput, "click")
Next

Thanks in advance.

Upload.JPG

Share this post


Link to post
Share on other sites
sammy1983
14 minutes ago, Danp2 said:

Have you tried using className instead of class?

Yup tried but not working.

Share this post


Link to post
Share on other sites
Danp2

"Not working" doesn't really tell us much. First thing you need to do is determine if you are even finding the desired element. Try adding a ConsoleWrite to see which elements are being processed in the For loop.

Is this a public website? Can you share the URL?

Share this post


Link to post
Share on other sites
sammy1983
1 minute ago, Danp2 said:

"Not working" doesn't really tell us much. First thing you need to do is determine if you are even finding the desired element. Try adding a ConsoleWrite to see which elements are being processed in the For loop.

Is this a public website? Can you share the URL?

I meant that I used "classname" as well and it didn't work. I'll try consolewrite and share the results.

It's an internal Sharepoint link. Unfortunately, I can't share the link. Hope you understand.

Share this post


Link to post
Share on other sites
sammy1983
10 hours ago, Danp2 said:

These are details that help, since you aren't the only one who has access to a Sharepoint site. B)

Since it's  internal and against company's policies I couldn't share the link. :(

Share this post


Link to post
Share on other sites
mLipok

Did you check frames ?


Signature beginning:   Wondering who uses AutoIT and what it can be used for ?
* GHAPI UDF - modest begining - comunication with GitHub REST API *
ADO.au3 UDF     POP3.au3 UDF     XML.au3 UDF    How to use IE.au3  UDF with  AutoIt v3.3.14.x  for other useful stuff click the following button

Spoiler

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind. 

My contribution (my own projects): * Debenu Quick PDF Library - UDF * Debenu PDF Viewer SDK - UDF * Acrobat Reader - ActiveX Viewer * UDF for PDFCreator v1.x.x * XZip - UDF * AppCompatFlags UDF * CrowdinAPI UDF * _WinMergeCompare2Files() * _JavaExceptionAdd() * _IsBeta() * Writing DPI Awareness App - workaround * _AutoIt_RequiredVersion() * Chilkatsoft.au3 UDF * TeamViewer.au3 UDF * JavaManagement UDF * VIES over SOAP * WinSCP UDF * GHAPI UDF - modest begining - comunication with GitHub REST API *

My contribution to others projects or UDF based on  others projects: * _sql.au3 UDF  * POP3.au3 UDF *  RTF Printer - UDF * XML.au3 UDF * ADO.au3 UDF SMTP Mailer UDF *

Useful links: * Forum Rules * Forum etiquette *  Forum Information and FAQs * How to post code on the forum * AutoIt Online Documentation * AutoIt Online Beta Documentation * SciTE4AutoIt3 getting started * Convert text blocks to AutoIt code * Games made in Autoit * Programming related sites * Polish AutoIt Tutorial * DllCall Code Generator * 

Wiki: Expand your knowledge - AutoIt Wiki * Collection of User Defined Functions * How to use HelpFile * Good coding practices in AutoIt * 

IE Related:  * How to use IE.au3  UDF with  AutoIt v3.3.14.x * Why isn't Autoit able to click a Javascript Dialog? * Clicking javascript button with no ID * IE document >> save as MHT file * IETab Switcher (by LarsJ ) * HTML Entities * _IEquerySelectorAll() (by uncommon) * 

I encourage you to read: * Global Vars * Best Coding Practices * Please explain code used in Help file for several File functions * OOP-like approach in AutoIt * UDF-Spec Questions *  EXAMPLE: How To Catch ConsoleWrite() output to a file or to CMD *

"Homo sum; humani nil a me alienum puto" - Publius Terentius Afer
"Program are meant to be read by humans and only incidentally for computers and execute" - Donald Knuth, "The Art of Computer Programming"
:naughty:  :ranting:, be  :) and       \\//_.

Anticipating Errors :  "Any program that accepts data from a user must include code to validate that data before sending it to the data store. You cannot rely on the data store, ...., or even your programming language to notify you of problems. You must check every byte entered by your users, making sure that data is the correct type for its field and that required fields are not empty."

Signature last update: 2018-03-17

Share this post


Link to post
Share on other sites
sammy1983
On ‎03‎/‎18‎/‎2018 at 2:53 PM, mLipok said:

Did you check frames ?

image.png.88d0ee00fbd129f7bb6d71103de9cbd4.png

Share this post


Link to post
Share on other sites
Juvigy

Try to locate the element based on .innerhtml or .innertext . After you click it you will quickly find another issue - your script will be paused on the "click" action until you close the file selection window that pops. The solution is found here:

 

Share this post


Link to post
Share on other sites
sammy1983
8 minutes ago, Juvigy said:

Try to locate the element based on .innerhtml or .innertext . After you click it you will quickly find another issue - your script will be paused on the "click" action until you close the file selection window that pops. The solution is found here:

 

Thanks Juvigy. Actually what I have found is that the script is unable to find any tagged element. Very strange. It's a MS Sharepoint site and when I tried _IETagNameAllGetCollection, all I am getting is HTML, HEAD and BODY. I am unable to fetch any info from the webpage. _IEDocReadHTML fetched nothing. I am kinda confused and stuck here.

image.thumb.png.91b26c696bc06640a6d16619c9d9c159.png

 

Edited by sammy1983

Share this post


Link to post
Share on other sites
Juvigy

I have sharepoints and i never had such issues. Try restarting the PC and update your Autoit if it is old. Are you sure your IE object points to the correct window?

Share this post


Link to post
Share on other sites
sammy1983
1 hour ago, Juvigy said:

I have sharepoints and i never had such issues. Try restarting the PC and update your Autoit if it is old. Are you sure your IE object points to the correct window?

I restarted the machine and updated Autoit to the new version. Please don't mind if I ask this. If you also have Sharepoint then can you try creating a script which can click on "Upload" button/link and let me know if it's working.

Share this post


Link to post
Share on other sites
Juvigy

This thing works for me:

Global $test,$oIE
Attach("https://sharepoint.com/xxx/eeee")
$test = _IEGetObjById($oIE, "QCB2_Button2")
_IEAction($test, "CLICK")
Exit

Func Attach($atachadres)
    Local $i = 1
    While 1
        $oIE = _IEAttach("", "instance", $i)
        If @error = $_IEStatus_NoMatch Then
            $oIE = 0
            ExitLoop
        EndIf
        If StringLeft(_IEPropertyGet($oIE, "locationurl"),StringLen($atachadres)) = $atachadres Then
            ConsoleWrite($i& "..." & _IEPropertyGet($oIE, "locationurl") & @CRLF)
            ExitLoop
        EndIf
        $i += 1
    WEnd
EndFunc

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.