Jump to content
_leo_

Excel RangeFind is not working

Recommended Posts

Hey there!¬†ūüėÉ

I am having a problem with the _Excel_RangeFind. I am trying to search for a value in a particular cell range. The script copies the value from the internet. Copying and saving as a variable is working fine, but as soon as it should find the value in excel, nothing happens. ( I am not getting an error)

#include <Excel.au3>
   
   Func Excel()
    Send("{CTRLDOWN}")
    Send("{c}")
    Send("{CTRLUP}")
    Local $sName = ClipGet() ;Text
    Local $sShortName = StringTrimRight ( $sName, 1) ;delete one letter
    Local $bOpenWorkBook = False, $oExcel = _Excel_Open()
    Local $sFilePath = "C:\Users\Acer\OneDrive\xyz.xlsx"
    Local $oWorkbook
    $oWorkbook = _Excel_BookAttach($sFilePath)
    If @error Then
      $oWorkbook = _Excel_BookOpen($oExcel, $sFilePath)
      $bOpenWorkBook = True
    EndIf
    sleep(15000)
    Send("{LWINDown}") 
    Send ("{up}") ;maximize window
    Send("{LWINup}") 
    sleep(1000)
    _Excel_RangeFind ($oWorkbook, $sShortName, "A3:A56")
   EndFunc

Is anyone familiar with this problem or am I just missing some basic stuff? 

Thanks for help!

Share this post


Link to post
Share on other sites

_Excel_RangeFind returns either a 2D Array of the results or error (see help file for return values).  Use _ArrayDisplay (requires #include <Array.au3> to show you the results.  Also try to use ControlSend rather than Send, Send can have be unpredictable, whereas ControlSend is targeted and less likely to have any issues.

Share this post


Link to post
Share on other sites
35 minutes ago, Nine said:

To make your script more robust, you can use excel method instead of using Send to maximize the window like this :

Const $xlMaximized = -4137
$oExcel.WindowState = $xlMaximizedÔĽŅ

 

Thanks! I included your suggestion in my script ūüôā

Share this post


Link to post
Share on other sites
7 hours ago, Subz said:

_Excel_RangeFind returns either a 2D Array of the results or error (see help file for return values).  Use _ArrayDisplay (requires #include <Array.au3> to show you the results.  Also try to use ControlSend rather than Send, Send can have be unpredictable, whereas ControlSend is targeted and less likely to have any issues.

Hey Subz

Thank you very much for helping me once again! I replaced the send() with the ControlSend() and added the Array.

Is is possible to let the RangeFind show the result by switching to it/ making it the active cell? (like ctrl+f in excel) Because I would like to RangeRead it afterwards. If it is showed in an array, I don't know how the RangeRead could work. 

Thank you again for the productive support!

Share this post


Link to post
Share on other sites

What happens if you have multiple results?  Either way you would just use the array[x][2] to get the address of the cell that was found.

Edited by Subz

Share this post


Link to post
Share on other sites

I strongly suggest to not mix the Excel UDF (uses COM to interact with Excel) and GUi automation like Send, ControlSend etc.
Most (if not all) things you can do with GUI automation can be done using COM. But COM does not interfere with the user and is much easier to debug.
Just my 2 cents worth ;)
 


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2019-10-24 - Version 1.4.14.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2019-11-30 - Version 1.4.0.0) - Download - General Help & Support - Example Scripts - Wiki
Outlook Tools (2019-07-22 - Version 0.6.0.0) - Download - General Help & Support - Wiki
ExcelChart (2017-07-21 - Version 0.4.0.1) - Download - General Help & Support - Example Scripts
PowerPoint (2017-06-06 - Version 0.0.5.0) - Download - General Help & Support
Excel - Example Scripts - Wiki
Word - Wiki
Task Scheduler (NEW 2019-12-03 - Version 1.5.1.0) - Download - General Help & Support - Wiki

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites
1 hour ago, Subz said:

What happens if you have multiple results?  Either way you would just use the array[x][2] to get the address of the cell that was found.

How?

In my case, there can not be multiple results since the range find is searching for numbers from A3 to A56. These cells only contain a numberation from 1 to 50. 

The problem I am facing right now is, that the script should run by itself, without me having to click away the _ArrayDisplay window. Is the rangefind executed and the therefore the array safed, even if I don't use _ArrayDisplay?

What I am trying right now is transforming the RangeFind array result (see screenshot) into a variable using the  _Arraytostring. (does that work like that?) I have problems creating a string only of "col 2" and "row 0" value.

local $sSuchergebnis = _Excel_RangeFind ($oWorkbook, $sNummername, "A3:A56")
   sleep(1000)
   local $sfinal = _Arraytostring($sSuchergebnis, 0, 0, 2, 2)

and then I would use the function Nine sugguested:

$oWorkBook.ActiveSheet.Range ($sfinal).Activate

to activite the cell.

Appreciate your support!

arraydisplay.png

Share this post


Link to post
Share on other sites

@water I assumed he was copying from a third-party product, since the copy occurred prior to Excel being opened.

@_leo_ Just use $sFinal[0][2] to get the result

local $aResult = _Excel_RangeFind ($oWorkbook, $sNummername, "A3:A56")
   sleep(1000)
   $oWorkBook.ActiveSheet.Range ($aResult[0][2]).ActivateÔĽŅ

 

Share this post


Link to post
Share on other sites

But I think he tries to automate the GUI again by activating the found cell. Using _Excel_RangeCopyPaste is the way I'd suggest.


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2019-10-24 - Version 1.4.14.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2019-11-30 - Version 1.4.0.0) - Download - General Help & Support - Example Scripts - Wiki
Outlook Tools (2019-07-22 - Version 0.6.0.0) - Download - General Help & Support - Wiki
ExcelChart (2017-07-21 - Version 0.4.0.1) - Download - General Help & Support - Example Scripts
PowerPoint (2017-06-06 - Version 0.0.5.0) - Download - General Help & Support
Excel - Example Scripts - Wiki
Word - Wiki
Task Scheduler (NEW 2019-12-03 - Version 1.5.1.0) - Download - General Help & Support - Wiki

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

You guys are awesome! Thank you for giving this crazy support! 

@water Thank you for the spark of wisdom :) The next line in the script is with the RangeRead (not with ctrl c). 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Rskm
      Hi, I am using excel as input media for my program. The excel file (i tried with .xls, .xlsx and .xlsm format) has inputs which the autoit script reads during the run and performs few calculations. Some times (not always), after the run, when i try to open the excel file manually, the file doesnt open at all in excel. see the screenshot attached. However, if the execute the autoit script, the scripts still reads the existing data from that excel and performs the calcs. I copied the excel file to another computer and there too, it doesnt open.  So, after this, i cannot edit the excel forever (if i need to change any inputs). It is only this particular file that got affected. other excel files works normal.  What could be the problem here.  please help as this is a new challenge for me during my program development. 

    • By Taxyo
      Hi,
       
      I've been trying to automate modification of an excel file and the last thing I am stuck on is deleting all the rows where the value of Column 13 is 0. 
      I believe the error is due to me not fully understanding the syntax so this is where I'm stuck: 
       
      Func Hotkey2() Global $aUsedRange = _Excel_RangeRead($oWorkbook, 1) _ArrayDisplay($aUsedRange) For $iRow = UBound($aUsedRange) - 1 to 3 Step -1 If $aUsedRange[$iRow][13] = 0 Then _Excel_RangeDelete($oWorkbook.Worksheets(1), $aUsedRange[$iRow] & ":" & $aUsedRange[$iRow], default, 1) If @error Then Exit MsgBox($MB_SYSTEMMODAL, "Excel UDF: _Excel_RangeDelete Example 2", "Error deleting rows." & @CRLF & "@error = " & @error & ", @extended = " & @extended) EndIf Next EndFunc  
      While my script properly locates the row which contains value 0 in Column 13, I am not sure how to set it to the corresponding row in the excel workbook?  My above experiment gives me $vRange error and I've been toying around with it to no avail. The only way I get the Script to delete a row is by actually specifying "4:4" or "6:8" etc. 
      Where am I going wrong?
       
      Thanks! 
    • By Most
      #include <Array.au3> #include <Excel.au3> #include <MsgBoxConstants.au3> ; Create application object and open an example workbook Local $oExcel = _Excel_Open() If @error Then Exit MsgBox($MB_SYSTEMMODAL, "Excel UDF: _Excel_RangeRead Example", "Error creating the Excel application object." & @CRLF & "@error = " & @error & ", @extended = " & @extended) Local $oWorkbook = _Excel_BookOpen($oExcel, @ScriptDir & "\trans.xlsx") If @error Then MsgBox($MB_SYSTEMMODAL, "Excel UDF: _Excel_RangeRead Example", "Error opening workbook '" & @ScriptDir & "\trans.xlsx'." & @CRLF & "@error = " & @error & ", @extended = " & @extended) _Excel_Close($oExcel) Exit EndIf ; ***************************************************************************** ; Read data from a single cell on the active sheet of the specified workbook ; ***************************************************************************** Local $sResult = _Excel_RangeRead($oWorkbook, Default, "A1") If @error Then Exit MsgBox($MB_SYSTEMMODAL, "Excel UDF: _Excel_RangeRead Example 1", "Error reading from workbook." & @CRLF & "@error = " & @error & ", @extended = " & @extended) MsgBox($MB_SYSTEMMODAL, "Excel UDF: _Excel_RangeRead Example 1", "Data successfully read." & @CRLF & "Value of cell A1: " & $sResult) Hi, all.
      Ok, here is the deal. I have simple excel file called trans.xlsx. It's located in the directory of script. In general i don't care where to store it. 
      What i do need is to open excel file and copy one by one numbers from cells. I've tried different ways, examples. But i only get error, says: error = 3, extended = 1. I saw different posts from different years. I even tried to use simple example from manual file. But always get error.

      In general my goal get numbers one by one and post it to let's say search filed in my PC one by one. Or to notepad (but one by one, in kind of loop). 
      I've learned how to copy or show in message box some info from other apps. But with excel i'm stuck. 

      I'm able to open needed window based on "title" of excel. But i don't succeed of copying info from cells. 

      Would be appreciate for any help. 
      So, in this code i'm trying at least to read from cell A1. Doesn't matter what Sheet. 

      I use Windows 10, Excel for Office 365. 
      Thank you in advance. 
    • By VinMe
      Dear all, i am unable to open a xml file to excel in the "xml table format" Please help me out in where i am missing
      Local $strFileToOpen = _WinAPI_OpenFileDlg('Select xml file', @WorkingDir, 'All Files(*.*)', 1, '', '', BitOR($OFN_PATHMUSTEXIST, $OFN_FILEMUSTEXIST, $OFN_HIDEREADONLY)) Global $xlXmlLoadImportToList = 2 ; Places the contents of the XML data file in an XML table $oExcel = _Excel_Open() $oWorkbook1=$oExcel.Workbooks.OpenXML($strFileToOpen, "", $xlXmlLoadImportToList) If $strFileToOpen <> False Then     Local $oWorkbook1 = _Excel_BookOpen($oExcel, $strFileToOpen) EndIf Error i am getting is:
      ......\81e_Compare_v1.au3" (46) : ==> The requested action with this object has failed.:
      $oWorkbook1=$oExcel.Workbooks.OpenXML($strFileToOpen, "", $xlXmlLoadImportToList)
      $oWorkbook1=$oExcel.Workbooks^ ERROR
      >Exit code: 1    Time: 7.338
    • By VinMe
      Dear all, 
      I am unable to get the right result after applying the filter to the excel. please let me know on the same.
      issue: After applying the filter the output $lastRow11 not giving the right output of complete visible rows. (its breaking at row skips)
       
      ;DATA EXTRACTION FROM LOC EXCEL
      ;=============================================================================
      $oWorkbook = _Excel_BookAttach($sWorkbook)
      Local $sMSN = InputBox("MSN NO", "Enter MSN in XX FORMAT", "")
      ;~ Local $LastRow1 = ($oWorkbook.ACTIVESHEET.Range("A1").SpecialCells($xlCellTypeLastCell).Row)
      $LastRow1 = $oWorkbook.ActiveSheet.UsedRange.Rows.Count
      MsgBox(0, "lastrow1", $LastRow1)
      _Excel_FilterSet($oWorkbook, $oWorkbook.activesheet, "AF1", 32, "*" & $sMSN & "*")
      Local $oLocDS = $oWorkbook.ActiveSheet.Range("S1:S" & $LastRow1).SpecialCells($xlCellTypeVisible)
      Local $LastRow11 = $oLocDS.rows.count    ;error output
      MsgBox(0, "lastrow11", $LastRow11)
      Local $aLocDS1 = _Excel_RangeRead($oWorkbook, Default, $oLocDS)
      Local $oLocNr = $oWorkbook.ActiveSheet.Range("A1:A" & $LastRow1).SpecialCells($xlCellTypeVisible)
      Local $aLocNr1 = _Excel_RangeRead($oWorkbook, Default, $oLocNr)
      _ArrayDisplay($aLocDS1)
      _ArrayDisplay($aLocNr1)
      _ArrayTrim($aLocDS1, 6, 1)
      _ArrayTrim($aLocNr1, 6, 1)
      _ArrayTrim($aLocNr1, 6, 0)
      _ArrayDisplay($aLocDS1)
      _ArrayDisplay($aLocNr1)
×
×
  • Create New...