Jump to content
DavidLago

AutoIT with Windows 10

Recommended Posts

DavidLago

Hello.

Anyone suffering from some Bugs on Windows 10 when using AutoIT?

I've seen some. 

Currently, I'm working a way around this:

$oIE = _IECreate("intranet.website.net", 1, 1, 0) ;works
WinSetState("[CLASS:IEFrame]","",@SW_MAXIMIZE) ;works
Local $oForms = _IEFormGetCollection($oIE) ; <--- crash

Console says:

--> IE.au3 T3.0-2 Warning from function _IEAttach, $_IESTATUS_NoMatch
"C:\Program Files (x86)\AutoIt3\Include\IE.au3" (1784) : ==> The requested action with this object has failed.:
Return SetError($_IESTATUS_Success, 0, $oObject.document)
Return SetError($_IESTATUS_Success, 0, $oObject^ ERROR

 

Same code on a windows 7 and 8 works.

 


Just a server analyst that has never been into programming that much. So, small fish here :)

Share this post


Link to post
Share on other sites
mLipok

Did you read this:

  ie.au3 UDF with AutoIt v3.3.14.x 

??

 


Signature beginning:   Wondering who uses AutoIT and what it can be used for ?
* GHAPI UDF - modest begining - comunication with GitHub REST API *
ADO.au3 UDF     POP3.au3 UDF     XML.au3 UDF    How to use IE.au3  UDF with  AutoIt v3.3.14.x  for other useful stuff click the following button

Spoiler

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind. 

My contribution (my own projects): * Debenu Quick PDF Library - UDF * Debenu PDF Viewer SDK - UDF * Acrobat Reader - ActiveX Viewer * UDF for PDFCreator v1.x.x * XZip - UDF * AppCompatFlags UDF * CrowdinAPI UDF * _WinMergeCompare2Files() * _JavaExceptionAdd() * _IsBeta() * Writing DPI Awareness App - workaround * _AutoIt_RequiredVersion() * Chilkatsoft.au3 UDF * TeamViewer.au3 UDF * JavaManagement UDF * VIES over SOAP * WinSCP UDF * GHAPI UDF - modest begining - comunication with GitHub REST API *

My contribution to others projects or UDF based on  others projects: * _sql.au3 UDF  * POP3.au3 UDF *  RTF Printer - UDF * XML.au3 UDF * ADO.au3 UDF SMTP Mailer UDF *

Useful links: * Forum Rules * Forum etiquette *  Forum Information and FAQs * How to post code on the forum * AutoIt Online Documentation * AutoIt Online Beta Documentation * SciTE4AutoIt3 getting started * Convert text blocks to AutoIt code * Games made in Autoit * Programming related sites * Polish AutoIt Tutorial * DllCall Code Generator * 

Wiki: Expand your knowledge - AutoIt Wiki * Collection of User Defined Functions * How to use HelpFile * Good coding practices in AutoIt * 

IE Related:  * How to use IE.au3  UDF with  AutoIt v3.3.14.x * Why isn't Autoit able to click a Javascript Dialog? * Clicking javascript button with no ID * IE document >> save as MHT file * IETab Switcher (by LarsJ ) * HTML Entities * _IEquerySelectorAll() (by uncommon) * 

I encourage you to read: * Global Vars * Best Coding Practices * Please explain code used in Help file for several File functions * OOP-like approach in AutoIt * UDF-Spec Questions *  EXAMPLE: How To Catch ConsoleWrite() output to a file or to CMD *

"Homo sum; humani nil a me alienum puto" - Publius Terentius Afer
"Program are meant to be read by humans and only incidentally for computers and execute" - Donald Knuth, "The Art of Computer Programming"
:naughty:  :ranting:, be  :) and       \\//_.

Anticipating Errors :  "Any program that accepts data from a user must include code to validate that data before sending it to the data store. You cannot rely on the data store, ...., or even your programming language to notify you of problems. You must check every byte entered by your users, making sure that data is the correct type for its field and that required fields are not empty."

Signature last update: 2018-03-17

Share this post


Link to post
Share on other sites
Danp2

Adding a COM error handler won't fix the fact that _IECreate fails with $_IESTATUS_NoMatch.

Edit:

Seems like the issue is that the page isn't loaded before the call to _IEFormGetCollection. Adding a call to _IELoadWait seems to solve it.

Edited by Danp2

Share this post


Link to post
Share on other sites
DavidLago

Did you read this:

  ie.au3 UDF with AutoIt v3.3.14.x 

??

 

Yep, it's clarifying, thanks a lot, but not the issue, I think... I've had a debug line for every command on my script before just to make sure.

I also had to go through this problem before: 
https://www.autoitscript.com/forum/topic/137279-ieau3-wend-error/ 

Adding a COM error handler won't fix the fact that _IECreate fails with $_IESTATUS_NoMatch.

Yup.

Weird thing that it works perfectly in the same AIT version, on W7 and W8, all with IE11.

 

Edited by DavidLago

Just a server analyst that has never been into programming that much. So, small fish here :)

Share this post


Link to post
Share on other sites
DavidLago

Seems like the issue is that the page isn't loaded before the call to _IEFormGetCollection. Adding a call to _IELoadWait seems to solve it.

I had already tried that too. 

It crashes somewhere else:

 

$oIE = _IECreate("intranet.site.net", 1, 1, 0)
local $Teste1 = _IELoadWait($oIE)
ConsoleWrite("Output from IELOADWAIT is " & @error & @CRLF)


ConsoleWrite says:

 

--> Press Ctrl+Alt+F5 to Restart or Ctrl+Break to Stop
--> IE.au3 T3.0-2 Warning from function _IEAttach, $_IESTATUS_NoMatch
--> IE.au3 T3.0-2 Error from function _IELoadWait, $_IESTATUS_ClientDisconnected (-2147023179, Browser has been deleted prior to operation.)
Output from IELOADWAIT is 9
"C:\Program Files (x86)\AutoIt3\Include\IE.au3" (1784) : ==> The requested action with this object has failed.:
Return SetError($_IESTATUS_Success, 0, $oObject.document)
Return SetError($_IESTATUS_Success, 0, $oObject^ ERROR
->14:06:44 AutoIt3.exe ended.rc:1
>Exit code: 1    Time: 5.755

 


Just a server analyst that has never been into programming that much. So, small fish here :)

Share this post


Link to post
Share on other sites
DavidLago

Looks like the site decided you have no rights to look at it.

Hmmm that's what this means? I didn't really know what it was. Thought it was the IE UDF acting up...


Just a server analyst that has never been into programming that much. So, small fish here :)

Share this post


Link to post
Share on other sites
DavidLago

Does anyone know why that happens?

Local $ieLoadWait = _IELoadWait($oIE)
MsgBox(0, "Cod Error", @error)

 

MsgBox says 4:

Success: 1. 
Failure: 0 and sets the @error flag to non-zero. 
@error: 1 ($_IEStatus_GeneralError) - General Error
3 ($_IEStatus_InvalidDataType) - Invalid Data Type
4 ($_IEStatus_InvalidObjectType) - Invalid Object Type
6 ($_IEStatus_LoadWaitTimeout) - Load Wait Timeout
8 ($_IEStatus_AccessIsDenied) - Access Is Denied
9 ($_IEStatus_ClientDisconnected) - Client Disconnected 
@extended: Contains invalid parameter number 

 

 

Why Invalid Object Type?

 

Just a server analyst that has never been into programming that much. So, small fish here :)

Share this post


Link to post
Share on other sites
DavidLago

Yeah, Dan. Its an intranet site for the Citrix Environment. Even if I call as a http://, it automatically turns to https://


Just a server analyst that has never been into programming that much. So, small fish here :)

Share this post


Link to post
Share on other sites
mLipok

Yeah, Dan. Its an intranet site for the Citrix Environment. Even if I call as a http://, it automatically turns to https://

so, I think you need initially use url like this:

$oIE = _IECreate("https://intranet.site.net", 1, 1, 0)

 

Edited by mLipok

Signature beginning:   Wondering who uses AutoIT and what it can be used for ?
* GHAPI UDF - modest begining - comunication with GitHub REST API *
ADO.au3 UDF     POP3.au3 UDF     XML.au3 UDF    How to use IE.au3  UDF with  AutoIt v3.3.14.x  for other useful stuff click the following button

Spoiler

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind. 

My contribution (my own projects): * Debenu Quick PDF Library - UDF * Debenu PDF Viewer SDK - UDF * Acrobat Reader - ActiveX Viewer * UDF for PDFCreator v1.x.x * XZip - UDF * AppCompatFlags UDF * CrowdinAPI UDF * _WinMergeCompare2Files() * _JavaExceptionAdd() * _IsBeta() * Writing DPI Awareness App - workaround * _AutoIt_RequiredVersion() * Chilkatsoft.au3 UDF * TeamViewer.au3 UDF * JavaManagement UDF * VIES over SOAP * WinSCP UDF * GHAPI UDF - modest begining - comunication with GitHub REST API *

My contribution to others projects or UDF based on  others projects: * _sql.au3 UDF  * POP3.au3 UDF *  RTF Printer - UDF * XML.au3 UDF * ADO.au3 UDF SMTP Mailer UDF *

Useful links: * Forum Rules * Forum etiquette *  Forum Information and FAQs * How to post code on the forum * AutoIt Online Documentation * AutoIt Online Beta Documentation * SciTE4AutoIt3 getting started * Convert text blocks to AutoIt code * Games made in Autoit * Programming related sites * Polish AutoIt Tutorial * DllCall Code Generator * 

Wiki: Expand your knowledge - AutoIt Wiki * Collection of User Defined Functions * How to use HelpFile * Good coding practices in AutoIt * 

IE Related:  * How to use IE.au3  UDF with  AutoIt v3.3.14.x * Why isn't Autoit able to click a Javascript Dialog? * Clicking javascript button with no ID * IE document >> save as MHT file * IETab Switcher (by LarsJ ) * HTML Entities * _IEquerySelectorAll() (by uncommon) * 

I encourage you to read: * Global Vars * Best Coding Practices * Please explain code used in Help file for several File functions * OOP-like approach in AutoIt * UDF-Spec Questions *  EXAMPLE: How To Catch ConsoleWrite() output to a file or to CMD *

"Homo sum; humani nil a me alienum puto" - Publius Terentius Afer
"Program are meant to be read by humans and only incidentally for computers and execute" - Donald Knuth, "The Art of Computer Programming"
:naughty:  :ranting:, be  :) and       \\//_.

Anticipating Errors :  "Any program that accepts data from a user must include code to validate that data before sending it to the data store. You cannot rely on the data store, ...., or even your programming language to notify you of problems. You must check every byte entered by your users, making sure that data is the correct type for its field and that required fields are not empty."

Signature last update: 2018-03-17

Share this post


Link to post
Share on other sites
DavidLago

Hello, guys.

Thanks for the help!

$oIE = _IECreate("https://intranet.site.net", 1, 1, 0)

Sleep(100)

$oIE = _IEAttach("Citrix Access Gateway - Internet Explorer") ;title copied from AU3Info
MsgBox(0, "Cod Error1", @error)

Local $ieLoadWait = _IELoadWait($oIE)
MsgBox(0, "Cod Error2", @error)

Exit

I did what you suggested (and some other things too). Still can't seem to get past the IELoadWait errors. Usually they return 4 or 3 from my tests.

For this one in the code up there: 

cod error1, it returns me 7,
7 ($_IEStatus_NoMatch) - No Match

cod error2 returns me 3.
3 ($_IEStatus_InvalidDataType) - Invalid Data Type
 

I didn't know that working with IE was so hard haha

 

 


Just a server analyst that has never been into programming that much. So, small fish here :)

Share this post


Link to post
Share on other sites
Danp2

    cod error1, it returns me 7,

7 ($_IEStatus_NoMatch) - No Match


This is telling you the the _IEAttach failed. You might try shortening the title text (ie: "Citrix Access Gateway") to see if that make a difference. You need to have error checking throughout your script because when one function fails (_IEAttach) then is doesn't make sense to continue with other commands (_IELoadWait) that depend on the earlier functions success.

Share this post


Link to post
Share on other sites
DavidLago

Dan,

I just found out that it works on Win7. I might just end this script and put to run on a W7. I don't really know why, but the function (in a clean script) works on W7 and doesn't on W10.

But I'll continue posting the results here, until I find a proper solution.


Just a server analyst that has never been into programming that much. So, small fish here :)

Share this post


Link to post
Share on other sites
DavidLago

But I can say that a bunch of funcions in the IE UDF doesn't work on W10. Maybe the author should be notified, I think it's worth to look into.


Just a server analyst that has never been into programming that much. So, small fish here :)

Share this post


Link to post
Share on other sites
TouchOdeath

try this:

#include <IE.au3>
Local $oIE = _IECreate("https://intranet.website.net")
If IsObj($oIE) Then
    WinSetState("[CLASS:IEFrame]", "", @SW_MAXIMIZE)
    Local $oForms = _IEFormGetCollection($oIE)
If IsObj($oForms) Then
    ;the rest of your code
Else
Msgbox(0,'','error oforms')
EndIf
Else
Msgbox(0,'','error oIE')
EndIf

Read the parameters for _IECreate.  The first parameter if set to 1 will try and match a window, you don't want this.  Thats why your getting the 'No match' because yes, it didn't match any existing windows because the window doesn't exist.

Edited by TouchOdeath

Share this post


Link to post
Share on other sites
noobest

I'm not sure if it's OS related.

I've got a lot of issues with the IE UDF on Windows 10 but also have issues for Windows Server 2008 R2. (Both of these are running IE11)

I don't have these issues on IE9 (tested on Windows Server 2008 R2 and Windows 7).
It also works flawlessly on IE8 (tested on Windows XP)

 

The wierd thing is that it does sometimes work flawlessly on IE11 but often fails miserably and crashes. (without any changes on my side)

Functions such as _IEGetObjByName are unreliable.

_IEGetObjByName($oIE, "unit1")

Errorlog:
"C:\Program Files (x86)\AutoIt3\Include\IE.au3" (1875) : ==> The requested action with this object has failed.:
If IsObj($oObject.document.GetElementsByName($sName).item($iIndex)) Then
If IsObj($oObject.document^ ERROR


Even _IENavigate doesn't always work properly. (this function does work most of the time though)
I'm currently using $oIE.navigate($url) as a workaround. It seems to work better for some unknown reason.

It would be awesome if the author could take a look but for now, i'll be downgrading to an older version of IE.

Share this post


Link to post
Share on other sites
mLipok

@noobest

Functions such as _IEGetObjByName are unreliable.

_IEGetObjByName($oIE, "unit1")

Errorlog:
"C:\Program Files (x86)\AutoIt3\Include\IE.au3" (1875) : ==> The requested action with this object has failed.:
If IsObj($oObject.document.GetElementsByName($sName).item($iIndex)) Then
If IsObj($oObject.document^ ERROR

I suppose you are using AutoIt 3.3.14.x
It is know bug, and I hope this will be fixed in next Beta/Release.

 

Even _IENavigate doesn't always work properly. (this function does work most of the time though)
I'm currently using $oIE.navigate($url) as a workaround. It seems to work better for some unknown reason.

It would be awesome if the author could take a look but for now, i'll be downgrading to an older version of IE.

Please provide any example for your _IENavigate issue.
 

mLipok

 

btw.

Which one "older version of IE.au3" do you mean ?


Signature beginning:   Wondering who uses AutoIT and what it can be used for ?
* GHAPI UDF - modest begining - comunication with GitHub REST API *
ADO.au3 UDF     POP3.au3 UDF     XML.au3 UDF    How to use IE.au3  UDF with  AutoIt v3.3.14.x  for other useful stuff click the following button

Spoiler

Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind. 

My contribution (my own projects): * Debenu Quick PDF Library - UDF * Debenu PDF Viewer SDK - UDF * Acrobat Reader - ActiveX Viewer * UDF for PDFCreator v1.x.x * XZip - UDF * AppCompatFlags UDF * CrowdinAPI UDF * _WinMergeCompare2Files() * _JavaExceptionAdd() * _IsBeta() * Writing DPI Awareness App - workaround * _AutoIt_RequiredVersion() * Chilkatsoft.au3 UDF * TeamViewer.au3 UDF * JavaManagement UDF * VIES over SOAP * WinSCP UDF * GHAPI UDF - modest begining - comunication with GitHub REST API *

My contribution to others projects or UDF based on  others projects: * _sql.au3 UDF  * POP3.au3 UDF *  RTF Printer - UDF * XML.au3 UDF * ADO.au3 UDF SMTP Mailer UDF *

Useful links: * Forum Rules * Forum etiquette *  Forum Information and FAQs * How to post code on the forum * AutoIt Online Documentation * AutoIt Online Beta Documentation * SciTE4AutoIt3 getting started * Convert text blocks to AutoIt code * Games made in Autoit * Programming related sites * Polish AutoIt Tutorial * DllCall Code Generator * 

Wiki: Expand your knowledge - AutoIt Wiki * Collection of User Defined Functions * How to use HelpFile * Good coding practices in AutoIt * 

IE Related:  * How to use IE.au3  UDF with  AutoIt v3.3.14.x * Why isn't Autoit able to click a Javascript Dialog? * Clicking javascript button with no ID * IE document >> save as MHT file * IETab Switcher (by LarsJ ) * HTML Entities * _IEquerySelectorAll() (by uncommon) * 

I encourage you to read: * Global Vars * Best Coding Practices * Please explain code used in Help file for several File functions * OOP-like approach in AutoIt * UDF-Spec Questions *  EXAMPLE: How To Catch ConsoleWrite() output to a file or to CMD *

"Homo sum; humani nil a me alienum puto" - Publius Terentius Afer
"Program are meant to be read by humans and only incidentally for computers and execute" - Donald Knuth, "The Art of Computer Programming"
:naughty:  :ranting:, be  :) and       \\//_.

Anticipating Errors :  "Any program that accepts data from a user must include code to validate that data before sending it to the data store. You cannot rely on the data store, ...., or even your programming language to notify you of problems. You must check every byte entered by your users, making sure that data is the correct type for its field and that required fields are not empty."

Signature last update: 2018-03-17

Share this post


Link to post
Share on other sites
DavidLago

mLipok

btw.

Which one "older version of IE.au3" do you mean ?

[2]


Just a server analyst that has never been into programming that much. So, small fish here :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • Dreamfire
      By Dreamfire
      Hi,
      Since today, exe's are being flagged as having a trojan by Windows Defender (Fuery.B!cl)
      Version:  3.3.14.3 - SciTE Version 3.7.3



       

    • PramodR
      By PramodR
      Hello,
      I have to execute below block of code in elevated previllage, as that particular wmic class will work only with admin previlage.
      i am getting out put when i launch autoit as administrator,  but i will not be able to launch autoit as admin in this particular case but my user have admin rights.
      is there any better way i can run those command as administrator.?
      tried below steps:
      i have tried #RequireAdmin but that creates a user prompt  Tried using Runas command but gives error as wrong username or password , stuck with that step.  
       
    • dwaynek
      By dwaynek
      traytip isn't working in windows 10. nothing happens when i use the Traytip command.
      here's a simple script i used:
      TrayTip("I'm a title", "I'm the message", 5) i tried changing the registry setting HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced ( which didn't have EnableBalloonTips) and creating a DWORD entry called EnableBalloonTips and setting it to 1 and logging off then back in. that did not resolve the problem.
      i'm running Windows 10 v1709 b16299.431
    • antonioj84
      By antonioj84
      Hi all to the forum guru and expert I am trying to  automate this. in the registry  I have the network profile name network 2 and network   I want to  change their  CATEGORY  to Private .  Can someone lead me in the right direction.
      Private is 1 and Public is 0
      #RequireAdmin Global $sHKLMRoot = @OSArch = "x64" ? "HKLM64" : "HKLM" RegWrite($sHKLMRoot &"\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\NewNetworks" ,'/v NetworkList /t REG_MULTI_SZ /d 00000000 /f') see  attached picture below
      Much appreaciate
       

    • PhoenixPRO
      By PhoenixPRO
      When I try to automate this install program I can not get any of the buttons to click with the "ControlClick" function or any mouse movement to move the mouse to the and click it.  My OS is Windows 10 64Bit.  I have tried both 32bit and 64bit installs of Autoit V3 to no avail.
      I could not even get the run command to start the program until I used the variation of the command below in the script.
      With the script below the install program starts but will not click the "Next" button no matter what I do.
      Any help will be greatly appreciated.
      Thanks in advance.
       
      #include <MsgBoxConstants.au3>
      Opt("MouseCoordMode", 0) ;1=absolute, 0=relative to active window, 2=client
      Local $Success
      Run(@ComSpec & " /c " & 'C:\PhoenixPro_Install\RDXUtil\RDX_Tools_setup.exe', "C:\PhoenixPro_Install\RDXUtil", @SW_HIDE )

      WinWait("RDX Tools 1.62 - InstallShield Wizard", "Welcome to the InstallShield Wizard for RDX Tools 1.62")
      WinActivate("RDX Tools 1.62 - InstallShield Wizard", "Welcome to the InstallShield Wizard for RDX Tools 1.62")
      ControlClick ("RDX Tools 1.62 - InstallShield Wizard", "Welcome to the InstallShield Wizard for RDX Tools 1.62", 1639, "left", 1) ;Next Button
×