deepdown

Error : Variable used without being declared

29 posts in this topic

#1 ·  Posted (edited)

Hello im new here and i dont have experience on autoit can somebody help me? So the problem is :

Line 18 $sGuid = $sGuid[0] $sGuid = ERROR

The Script

#include "WinHttp.au3"
#include <String.au3>

Opt("MustDeclareVars", 1)

Local $hOpen = _WinHttpOpen()
Local $hConnect = _WinHttpConnect($hOpen, "[url=http://www.guidgenerator.com/]http://www.guidgenerator.com/[/url]")
Local $hRequest = _WinHttpOpenRequest($hConnect, "POST", "online-guid-generator.aspx")
Local $data = "txtCount=1&chkHypens=On&Button1=Generate"
Local $data1 = "__VIEWSTATE=%2FwEPDwUJMTk1MDgwNTkxZBgBBR5fX0NvbnRyb2xzUmVxdWlyZVBvc3RCYWNrS2V5X18WAwUMY2hrVXBwZXJjYXNlBQtjaGtCcmFja2V0cwUJY2hrSHlwZW5zEP0U%2BOIYUuW3bpG4bQtW980Sr%2Fg%3D&__VIEWSTATEGENERATOR=247C709F&__EVENTVALIDATION=%2FwEWBwKJo9mYBgLJkuW4AwKyzJeLDALcw7KJAgKm%2FOiABwKM54rGBgL6g7v1A9pSCUBhX%2BccVPc3JQBvo3RVU1Zu&txtCount=1&chkHypens=on&Button1=Generate+some+GUIDs%21&txtResults="
Local $sHeader = "Content-Type: application/x-www-form-urlencoded" & @CRLF

_WinHttpSendRequest($hRequest, $sHeader, $WINHTTP_NO_REQUEST_DATA, StringLen($data1), 0)
_WinHttpWriteData($hRequest, $data1)
_WinHttpReceiveResponse($hRequest)

Local $response = _WinHttpReadData($hRequest)
Local $sGuid = _StringBetween($response, 'id="txtResults">', "")
$sGuid = $sGuid[0] ;convert from array to string

RegWrite("HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography", "MachineGuid", "REG_SZ", $sGuid)
TrayTip("MachineGUID:", "Changed to: " & $sGuid, 1000)

Sleep(2000)

_WinHttpCloseHandle($hOpen)
_WinHttpCloseHandle($hConnect)
_WinHttpCloseHandle($hRequest)
Edited by deepdown
Added code tags

Share this post


Link to post
Share on other sites



deepdown,

Welcome to the AutoIt forums. :)

You have a typo - change $sGuide in this line to $sGuid: ;)

Local $sGuide = _StringBetween($response, 'id="txtResults">', "")
M23

P.S. When you post code please use Code tags - see here how to do it. Then you get a scrolling box and syntax colouring as you can see above now I have added the tags. ;)


Any of my own code posted anywhere on the forum is available for use by others without any restriction of any kind._______My UDFs:

Spoiler

ArrayMultiColSort ---- Sort arrays on multiple columns
ChooseFileFolder ---- Single and multiple selections from specified path treeview listing
Date_Time_Convert -- Easily convert date/time formats, including the language used
ExtMsgBox --------- A highly customisable replacement for MsgBox
GUIExtender -------- Extend and retract multiple sections within a GUI
GUIFrame ---------- Subdivide GUIs into many adjustable frames
GUIListViewEx ------- Insert, delete, move, drag, sort, edit and colour ListView items
GUITreeViewEx ------ Check/clear parent and child checkboxes in a TreeView
Marquee ----------- Scrolling tickertape GUIs
NoFocusLines ------- Remove the dotted focus lines from buttons, sliders, radios and checkboxes
Notify ------------- Small notifications on the edge of the display
Scrollbars ----------Automatically sized scrollbars with a single command
StringSize ---------- Automatically size controls to fit text
Toast -------------- Small GUIs which pop out of the notification area

 

Share this post


Link to post
Share on other sites

#3 ·  Posted (edited)

Thank you Melba23

i try this before but this is not help this line is fixed but also the same error ;/ sorry for the mess

Edited by deepdown

Share this post


Link to post
Share on other sites

I just tried and got the error as you described. After doing the change as suggested by Melba23 then the error is gone.

Can you please post the error messages you get in the SciTE output pane?


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

Line 18 $sGuid = $sGuid[0] $sGuid = ERROR ]
Error : Variable used without being declared

Share this post


Link to post
Share on other sites

But $sGuid is being declared in line 17 (if you have removed the typo as Melba23 suggested).


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

Yes but he just offered me to change from $sGuide to $sGuid so i have already done it and the same problem i dont need to remove that all line boss

Share this post


Link to post
Share on other sites

If lines 17/18 look like this

Local $sGuid = _StringBetween($response, 'id="txtResults">', "")
$sGuid = $sGuid[0] ;convert from array to string

then I do not get the "Variable used without being declared" error message.


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

Hmm i do the same like you post but nothing change so i think the problem is not at the script thank you for the help

Share this post


Link to post
Share on other sites

Do you run it from Scite or have you recompiled the modified source (or not)?


This wonderful site allows debugging and testing regular expressions (many flavors available). An absolute must have in your bookmarks.
Another excellent RegExp tutorial. Don't forget downloading your copy of up-to-date pcretest.exe and pcregrep.exe here
RegExp tutorial: enough to get started
PCRE v8.33 regexp documentation latest available release and currently implemented in AutoIt beta.

SQLitespeed is another feature-rich premier SQLite manager (includes import/export). Well worth a try.
SQLite Expert (freeware Personal Edition or payware Pro version) is a very useful SQLite database manager.
An excellent eBook covering almost every aspect of SQLite3: a must-read for anyone doing serious work.
SQL tutorial (covers "generic" SQL, but most of it applies to SQLite as well)
A work-in-progress SQLite3 tutorial. Don't miss other LxyzTHW pages!
SQLite official website with full documentation (may be newer than the SQLite library that comes standard with AutoIt)

Share this post


Link to post
Share on other sites

I dont know really thats all what i know and it works before fine on vmware and now you see what i have :]] , maybe somebody have or can make a script like this to change the GUID?

Share this post


Link to post
Share on other sites

You need to validate the returns prior to working with a possible array..._StringBetween:

Return Value

 

Success: a 0-based array - element [0] contains the first found string. Failure: sets the @error flag to non-zero. @error: 1 - No strings found.

IEbyXPATH-Grab IE DOM objects by XPATH IEscriptRecord-Makings of an IE script recorder ExcelFromXML-Create Excel docs without excel installed GetAllWindowControls-Output all control data on a given window.

Share this post


Link to post
Share on other sites

Correct, the script needs some error checking.

But what the OP sees is a syntax error, not a run time error.


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

BTW:

What I think you need to change is the following line:

Local $hConnect = _WinHttpConnect($hOpen, "[url=http://www.guidgenerator.com/]http://www.guidgenerator.com/[/url]")

which should be

Local $hConnect = _WinHttpConnect($hOpen, "http://www.guidgenerator.com/")

This is caused by the forum software or a copy and paste error.


My UDFs and Tutorials:

Spoiler

UDFs:
Active Directory (NEW 2017-04-18 - Version 1.4.8.0) - Download - General Help & Support - Example Scripts - Wiki
OutlookEX (NEW 2017-02-27 - Version 1.3.1.0) - Download - General Help & Support - Example Scripts - Wiki
ExcelChart (2015-04-01 - Version 0.4.0.0) - Download - General Help & Support - Example Scripts
Excel - Example Scripts - Wiki
Word - Wiki
PowerPoint (2015-06-06 - Version 0.0.5.0) - Download - General Help & Support

Tutorials:
ADO - Wiki

 

Share this post


Link to post
Share on other sites

#15 ·  Posted (edited)

Here is also compiled script to .exe with the same name sorry i dont have any experience with this maybe somebody have skype and can check this ? or smth?

water here is the posting problem at the script this line is fine

Edited by deepdown

Share this post


Link to post
Share on other sites

If somebody could share working script like this would be awesome :ermm:>_<

Share this post


Link to post
Share on other sites

#17 ·  Posted (edited)

Sorry to chime in, but what's wrong with _WinAPI_CreateGUID()? Also what logical reason is there to change the machine GUID? I am curious.

Edited by guinness

_AdapterConnections()_AlwaysRun()_AppMon()_AppMonEx()_BinaryBin()_CheckMsgBox()_CmdLineRaw()_ContextMenu()_ConvertLHWebColor()/_ConvertSHWebColor()_DesktopDimensions()_DisplayPassword()_DotNet_Load()/_DotNet_Unload()_Fibonacci()_FileCompare()_FileCompareContents()_FileNameByHandle()_FilePrefix/SRE()_FindInFile()_GetBackgroundColor()/_SetBackgroundColor()_GetConrolID()_GetCtrlClass()_GetDirectoryFormat()_GetDriveMediaType()_GetFilename()/_GetFilenameExt()_GetHardwareID()_GetIP()_GetIP_Country()_GetOSLanguage()_GetSavedSource()_GetStringSize()_GetSystemPaths()_GetURLImage()_GIFImage()_GoogleWeather()_GUICtrlCreateGroup()_GUICtrlListBox_CreateArray()_GUICtrlListView_CreateArray()_GUICtrlListView_SaveCSV()_GUICtrlListView_SaveHTML()_GUICtrlListView_SaveTxt()_GUICtrlListView_SaveXML()_GUICtrlMenu_Recent()_GUICtrlMenu_SetItemImage()_GUICtrlTreeView_CreateArray()_GUIDisable()_GUIImageList_SetIconFromHandle()_GUIRegisterMsg()_GUISetIcon()_Icon_Clear()/_Icon_Set()_IdleTime()_InetGet()_InetGetGUI()_InetGetProgress()_IPDetails()_IsFileOlder()_IsGUID()_IsHex()_IsPalindrome()_IsRegKey()_IsStringRegExp()_IsSystemDrive()_IsUPX()_IsValidType()_IsWebColor()_Language()_Log()_MicrosoftInternetConnectivity()_MSDNDataType()_PathFull/GetRelative/Split()_PathSplitEx()_PrintFromArray()_ProgressSetMarquee()_ReDim()_RockPaperScissors()/_RockPaperScissorsLizardSpock()_ScrollingCredits_SelfDelete()_SelfRename()_SelfUpdate()_SendTo()_ShellAll()_ShellFile()_ShellFolder()_SingletonHWID()_SingletonPID()_Startup()_StringCompact()_StringIsValid()_StringRegExpMetaCharacters()_StringReplaceWholeWord()_StringStripChars()_Temperature()_TrialPeriod()_UKToUSDate()/_USToUKDate()_WinAPI_Create_CTL_CODE()_WinAPI_CreateGUID()_WMIDateStringToDate()/_DateToWMIDateString()Au3 script parsingAutoIt SearchAutoIt3 PortableAutoIt3WrapperToPragmaAutoItWinGetTitle()/AutoItWinSetTitle()CodingDirToHTML5FileInstallrFileReadLastChars()GeoIP databaseGUI - Only Close ButtonGUI ExamplesGUICtrlDeleteImage()GUICtrlGetBkColor()GUICtrlGetStyle()GUIEventsGUIGetBkColor()Int_Parse() & Int_TryParse()IsISBN()LockFile()Mapping CtrlIDsOOP in AutoItParseHeadersToSciTE()PasswordValidPasteBinPosts Per DayPreExpandProtect GlobalsQueue()Resource UpdateResourcesExSciTE JumpSettings INISHELLHOOKShunting-YardSignature CreatorStack()Stopwatch()StringAddLF()/StringStripLF()StringEOLToCRLF()VSCROLLWM_COPYDATAMore Examples...

Updated: 04/09/2015

Share this post


Link to post
Share on other sites

#18 ·  Posted (edited)

Because this one fit for me im not looking another i just want to fix this one but i have lot of troubles with scripts

Edited by deepdown

Share this post


Link to post
Share on other sites

#19 ·  Posted (edited)

Local $data1 = "__VIEWSTATE=%2FwEPDwUJMTk1MDgwNTkxZBgBBR5fX0NvbnRyb2xzUmVxdWlyZVBvc3RCYWNrS2V5X18WAwUMY2hrVXBwZXJjYXNlBQtjaGtCcmFja2V0cwUJY2hrSHlwZW5zEP0U%2BOIYUuW3bpG4bQtW980Sr%2Fg%3D&__VIEWSTATEGENERATOR=247C709F&__EVENTVALIDATION=%2FwEWBwKJo9mYBgLJkuW4AwKyzJeLDALcw7KJAgKm%2FOiABwKM54rGBgL6g7v1A9pSCUBhX%2BccVPc3JQBvo3RVU1Zu&txtCount=1&chkHypens=on&Button1=Generate+some+GUIDs%21&txtResults="

I think the problem is here because now the website have different script so can somebody help me with this to make it fine?

Now its like

id="__VIEWSTATE" value="/wEPDwUJMTk1MDgwNTkxZBgBBR5fX0NvbnRyb2xzUmVxdWlyZVBvc3RCYWNrS2V5X18WAwUMY2hrVXBwZXJjYXNlBQtjaGtCcmFja2V0cwUJY2hrSHlwZW5zlTxmXB9uTmJ06E8xNAeACXVU/qE="

Edited by deepdown

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now